aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-06-11 17:35:35 +1000
committerJustin Bedo <cu@cua0.org>2019-06-11 18:23:28 +1000
commite82405f0e8e4680aa6a39556810535e5c1d88487 (patch)
treec550684a6778030c406f9c4ccc13806374c09569 /default.nix
parent59f74368d35505d30d9f0fa51f223e1ae15a4d67 (diff)
slurm: allow salloc path to be overridden in stage calls
salloc was missing from defaults, preventing overriding of salloc path for each stage.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 54d0215..edb9377 100644
--- a/default.nix
+++ b/default.nix
@@ -38,7 +38,7 @@ let
fastp = callBionix ./tools/fastp.nix {};
slurm = attrs: bionix.extend (self: super: with self; rec {
- slurmDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; } // attrs;
+ slurmDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; salloc = "/usr/bin/salloc"; } // attrs;
slurm = attrs: (callPackage ./lib/slurm.nix {}) (slurmDefs // attrs);
exec = f: x: y: slurm (builtins.intersectAttrs slurmDefs x) (f (builtins.removeAttrs x (builtins.attrNames slurmDefs)) y);
});