aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-06-18 09:56:29 +1000
committerJustin Bedo <cu@cua0.org>2019-06-18 09:56:29 +1000
commitff8a11320db7131e488423e103937a342b82e652 (patch)
treeaeb2ed503e7017149d53535a2e5328657180219a /default.nix
parent27d69830a9475253c239ada6c161a938c52c01f8 (diff)
slurm: fix bug with srun
salloc must call srun to actually launch job on execution node rather than submission node
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index a0ecce0..9bc7b6c 100644
--- a/default.nix
+++ b/default.nix
@@ -38,7 +38,7 @@ let
fastp = callBionix ./tools/fastp.nix {};
slurm = attrs: bionix.extend (self: super: with self; rec {
- slurmDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; salloc = "/usr/bin/salloc"; } // attrs;
+ slurmDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; salloc = "/usr/bin/salloc"; srun = "/usr/bin/srun"; } // attrs;
slurm = attrs: (callPackage ./lib/slurm.nix {}) (slurmDefs // attrs);
exec = f: x: y: slurm (builtins.intersectAttrs slurmDefs x) (super.exec f (builtins.removeAttrs x (builtins.attrNames slurmDefs)) y);
});