aboutsummaryrefslogtreecommitdiff
path: root/examples/call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /examples/call.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'examples/call.nix')
-rw-r--r--examples/call.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/examples/call.nix b/examples/call.nix
index 8a38fdb..81a112e 100644
--- a/examples/call.nix
+++ b/examples/call.nix
@@ -2,9 +2,10 @@
# with the Platypus variant caller. Each input is preprocessed by aligning
# against a reference genome (defaults to GRCH38), fixing mate information, and
# marking duplicates. Finally platypus is called over all samples.
-{bionix ? import <bionix> {}
-,inputs
-,ref ? bionix.ref.grch38.seq }:
+{ bionix ? import <bionix> { }
+, inputs
+, ref ? bionix.ref.grch38.seq
+}:
with bionix;
with lib;
@@ -13,9 +14,10 @@ let
preprocess = flip pipe [
(bwa.align { inherit ref; })
(samtools.sort { nameSort = true; })
- (samtools.fixmate {})
- (samtools.sort {})
- (samtools.markdup {})
+ (samtools.fixmate { })
+ (samtools.sort { })
+ (samtools.markdup { })
];
-in platypus.call {} (map preprocess inputs)
+in
+platypus.call { } (map preprocess inputs)