aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-nextflow/nextflow-example1.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /examples/ex-nextflow/nextflow-example1.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'examples/ex-nextflow/nextflow-example1.nix')
-rw-r--r--examples/ex-nextflow/nextflow-example1.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/ex-nextflow/nextflow-example1.nix b/examples/ex-nextflow/nextflow-example1.nix
index 4f00431..687505c 100644
--- a/examples/ex-nextflow/nextflow-example1.nix
+++ b/examples/ex-nextflow/nextflow-example1.nix
@@ -1,7 +1,8 @@
# This is a translation of the Nextflow example found at
# https://www.nextflow.io/example1.html
-{ bionix ? import ./../.. {}
-, input ? ./sample.fa}:
+{ bionix ? import ./../.. { }
+, input ? ./sample.fa
+}:
with bionix;
with lib;
@@ -24,7 +25,8 @@ let
'';
};
-in pipe input [
+in
+pipe input [
splitSequences
(each reverse)
]