aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-nextflow/nextflow-example1.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ex-nextflow/nextflow-example1.nix')
-rw-r--r--examples/ex-nextflow/nextflow-example1.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/ex-nextflow/nextflow-example1.nix b/examples/ex-nextflow/nextflow-example1.nix
index 4f00431..687505c 100644
--- a/examples/ex-nextflow/nextflow-example1.nix
+++ b/examples/ex-nextflow/nextflow-example1.nix
@@ -1,7 +1,8 @@
# This is a translation of the Nextflow example found at
# https://www.nextflow.io/example1.html
-{ bionix ? import ./../.. {}
-, input ? ./sample.fa}:
+{ bionix ? import ./../.. { }
+, input ? ./sample.fa
+}:
with bionix;
with lib;
@@ -24,7 +25,8 @@ let
'';
};
-in pipe input [
+in
+pipe input [
splitSequences
(each reverse)
]