aboutsummaryrefslogtreecommitdiff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-02 15:35:22 +1100
committerJustin Bedo <cu@cua0.org>2018-11-02 15:40:27 +1100
commitf416c145204765a1566782f0ff384d3f65d6ed35 (patch)
tree0ce95603001956ac9941f95bd4870aa7a06cce28 /lib/types.nix
parentec77e9c3a9c2dc7425ee07474f525dd0a3d01fab (diff)
kallisto: init
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 4dbc6ff..ef9b1b7 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -21,7 +21,8 @@ let
in
rec {
- matchFiletype = sym: y: x: if x ? filetype then match x.filetype (defError (idft sym) y filetype) else abort "unknown filetype for ${sym}";
+ matchFiletype = sym: y: x: if x ? filetype then matchFiletype' sym y x.filetype else abort "unknown filetype for ${sym}";
+ matchFiletype' = sym: y: x: match x (defError (idft sym) y filetype);
filetype = make-type "filetype" {
fa = {};
fq = {};