aboutsummaryrefslogtreecommitdiff
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 4dbc6ff..ef9b1b7 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -21,7 +21,8 @@ let
in
rec {
- matchFiletype = sym: y: x: if x ? filetype then match x.filetype (defError (idft sym) y filetype) else abort "unknown filetype for ${sym}";
+ matchFiletype = sym: y: x: if x ? filetype then matchFiletype' sym y x.filetype else abort "unknown filetype for ${sym}";
+ matchFiletype' = sym: y: x: match x (defError (idft sym) y filetype);
filetype = make-type "filetype" {
fa = {};
fq = {};