aboutsummaryrefslogtreecommitdiff
path: root/test-tnpair.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-24 14:12:37 +1000
committerJustin Bedo <cu@cua0.org>2018-09-24 14:12:37 +1000
commit45af0256cf75fa28e75b6cf6874df0c48aac38cf (patch)
treef9848df3114486aae2528717dad17d56caf8d372 /test-tnpair.nix
parent9c99509719704112c786c194f715c64aaa5b03de (diff)
use a map in the test pipeline
Diffstat (limited to 'test-tnpair.nix')
-rw-r--r--test-tnpair.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/test-tnpair.nix b/test-tnpair.nix
index 40cb442..b3a41cb 100644
--- a/test-tnpair.nix
+++ b/test-tnpair.nix
@@ -13,7 +13,7 @@ let
normal = {name = "mysample2"; files = {input1 = ./example/sample2-1.fq; input2 = ./example/sample2-1.fq;};};};
processPair = { tumour, normal }: rec {
- alignments = { normal = sort(alignWithRG normal.name normal.files); tumour = sort (alignWithRG tumour.name tumour.files); };
+ alignments = mapAttrs (_: x: sort (alignWithRG x.name x.files)) { inherit normal tumour; };
variants = callVariants alignments;
};