aboutsummaryrefslogtreecommitdiff
path: root/tools/bowtie-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/bowtie-index.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/bowtie-index.nix')
-rw-r--r--tools/bowtie-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/bowtie-index.nix b/tools/bowtie-index.nix
index 98e529f..4554ad1 100644
--- a/tools/bowtie-index.nix
+++ b/tools/bowtie-index.nix
@@ -1,20 +1,19 @@
{ bionix
-, nixpkgs
, flags ? null
, seed ? 42
}:
ref:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "bowtie-index" { fa = _: true; } ref);
-stdenv.mkDerivation {
+stage {
name = "bowtie-index";
- buildInputs = [ bowtie2 ];
+ buildInputs = with pkgs; [ bowtie2 ];
buildCommand = ''
mkdir $out
bowtie2-build --seed ${toString seed} --threads $NIX_BUILD_CORES ${optionalString (flags != null) flags} ${ref} $out/ref