aboutsummaryrefslogtreecommitdiff
path: root/tools/bowtie-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bowtie-index.nix')
-rw-r--r--tools/bowtie-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/bowtie-index.nix b/tools/bowtie-index.nix
index 98e529f..4554ad1 100644
--- a/tools/bowtie-index.nix
+++ b/tools/bowtie-index.nix
@@ -1,20 +1,19 @@
{ bionix
-, nixpkgs
, flags ? null
, seed ? 42
}:
ref:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "bowtie-index" { fa = _: true; } ref);
-stdenv.mkDerivation {
+stage {
name = "bowtie-index";
- buildInputs = [ bowtie2 ];
+ buildInputs = with pkgs; [ bowtie2 ];
buildCommand = ''
mkdir $out
bowtie2-build --seed ${toString seed} --threads $NIX_BUILD_CORES ${optionalString (flags != null) flags} ${ref} $out/ref