aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-20 13:57:12 +1000
committerJustin Bedo <cu@cua0.org>2018-09-20 14:34:36 +1000
commit33a121a7bad5b2608cc41ce60ab3d65676541fa6 (patch)
treedbbce4154a85988f3bfd9b13d42ad5d37f04e18a /tools/bwa-index.nix
parentf0a8a4de59ea79f56e074ddd16eff0ce1782dfe8 (diff)
Wrap some tools and make an example pipeline
Diffstat (limited to 'tools/bwa-index.nix')
-rw-r--r--tools/bwa-index.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/bwa-index.nix b/tools/bwa-index.nix
new file mode 100644
index 0000000..8ca0eec
--- /dev/null
+++ b/tools/bwa-index.nix
@@ -0,0 +1,19 @@
+{ stdenv
+, lib
+, bwa
+}:
+
+ref:
+
+with lib;
+
+stdenv.mkDerivation {
+ name = "bwa-index";
+ buildInputs = [ bwa ];
+ buildCommand = ''
+ ln -s ${ref} ref.fa
+ bwa index ref.fa
+ mkdir $out
+ mv ref.fa.* $out
+ '';
+}