aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bwa-index.nix')
-rw-r--r--tools/bwa-index.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/bwa-index.nix b/tools/bwa-index.nix
new file mode 100644
index 0000000..8ca0eec
--- /dev/null
+++ b/tools/bwa-index.nix
@@ -0,0 +1,19 @@
+{ stdenv
+, lib
+, bwa
+}:
+
+ref:
+
+with lib;
+
+stdenv.mkDerivation {
+ name = "bwa-index";
+ buildInputs = [ bwa ];
+ buildCommand = ''
+ ln -s ${ref} ref.fa
+ bwa index ref.fa
+ mkdir $out
+ mv ref.fa.* $out
+ '';
+}