aboutsummaryrefslogtreecommitdiff
path: root/tools/cnvkit-batch.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/cnvkit-batch.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/cnvkit-batch.nix')
-rw-r--r--tools/cnvkit-batch.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/tools/cnvkit-batch.nix b/tools/cnvkit-batch.nix
index 113e0c9..7f7893f 100644
--- a/tools/cnvkit-batch.nix
+++ b/tools/cnvkit-batch.nix
@@ -1,17 +1,18 @@
-{bionix
-,targets ? null
-,annotations ? null
-,flags ? null
-,indexAttrs ? {}}:
+{ bionix
+, targets ? null
+, annotations ? null
+, flags ? null
+, indexAttrs ? { }
+}:
-{normals ? [], tumours}:
+{ normals ? [ ], tumours }:
with bionix;
with lib;
with types;
let
- getref = f: matchFiletype "cnvkit-batch" { bam = {ref, ...}: ref; } f;
+ getref = matchFiletype "cnvkit-batch" { bam = { ref, ... }: ref; };
refs = map getref normals ++ map getref tumours;
ref = head refs;
sorted = matchFileSorting "cnvkit-batch" { coord = _: true; };