aboutsummaryrefslogtreecommitdiff
path: root/tools/cnvkit-batch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cnvkit-batch.nix')
-rw-r--r--tools/cnvkit-batch.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/tools/cnvkit-batch.nix b/tools/cnvkit-batch.nix
index 113e0c9..7f7893f 100644
--- a/tools/cnvkit-batch.nix
+++ b/tools/cnvkit-batch.nix
@@ -1,17 +1,18 @@
-{bionix
-,targets ? null
-,annotations ? null
-,flags ? null
-,indexAttrs ? {}}:
+{ bionix
+, targets ? null
+, annotations ? null
+, flags ? null
+, indexAttrs ? { }
+}:
-{normals ? [], tumours}:
+{ normals ? [ ], tumours }:
with bionix;
with lib;
with types;
let
- getref = f: matchFiletype "cnvkit-batch" { bam = {ref, ...}: ref; } f;
+ getref = matchFiletype "cnvkit-batch" { bam = { ref, ... }: ref; };
refs = map getref normals ++ map getref tumours;
ref = head refs;
sorted = matchFileSorting "cnvkit-batch" { coord = _: true; };