aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-assemble.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/gridss-assemble.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/gridss-assemble.nix')
-rw-r--r--tools/gridss-assemble.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/tools/gridss-assemble.nix b/tools/gridss-assemble.nix
index 1a46eae..15e5ca6 100644
--- a/tools/gridss-assemble.nix
+++ b/tools/gridss-assemble.nix
@@ -1,12 +1,12 @@
{ bionix
-, bwaIndexAttrs ? {}
-, faidxAttrs ? {}
-, indexAttrs ? {}
-, collectMetricsAttrs ? {}
+, bwaIndexAttrs ? { }
+, faidxAttrs ? { }
+, indexAttrs ? { }
+, collectMetricsAttrs ? { }
, flags ? null
, config ? null
, heapSize ? "31g"
-, workdirs ? []
+, workdirs ? [ ]
, jobIndex ? null
, jobNodes ? null
}:
@@ -36,7 +36,7 @@ let
in
assert (all sorted inputs);
-assert (homoRef);
+assert homoRef;
stage rec {
name = "gridss-assemble";
@@ -70,6 +70,6 @@ stage rec {
touch $out
cp -r out.gridss.working $work
'';
- passthru.filetype = filetype.bam { ref = ref; sorting = sort.none {}; };
+ passthru.filetype = filetype.bam { inherit ref; sorting = sort.none { }; };
passthru.multicore = true;
}