aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-assemble.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/gridss-assemble.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/gridss-assemble.nix')
-rw-r--r--tools/gridss-assemble.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/gridss-assemble.nix b/tools/gridss-assemble.nix
index f57bc12..e5cb3ca 100644
--- a/tools/gridss-assemble.nix
+++ b/tools/gridss-assemble.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, bwaIndexAttrs ? {}
, faidxAttrs ? {}
, indexAttrs ? {}
@@ -9,9 +8,9 @@
, heapSize ? "31g"
}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
inputs:
@@ -36,9 +35,9 @@ in
assert (all sorted inputs);
assert (homoRef);
-stdenv.mkDerivation rec {
+stage rec {
name = "gridss-assemble";
- buildInputs = [ jre bwa ];
+ buildInputs = with pkgs; [ jre bwa ];
buildCommand = ''
TMPDIR=$(pwd)
ln -s ${ref} ref.fa