aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-assemble.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gridss-assemble.nix')
-rw-r--r--tools/gridss-assemble.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/gridss-assemble.nix b/tools/gridss-assemble.nix
index f57bc12..e5cb3ca 100644
--- a/tools/gridss-assemble.nix
+++ b/tools/gridss-assemble.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, bwaIndexAttrs ? {}
, faidxAttrs ? {}
, indexAttrs ? {}
@@ -9,9 +8,9 @@
, heapSize ? "31g"
}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
inputs:
@@ -36,9 +35,9 @@ in
assert (all sorted inputs);
assert (homoRef);
-stdenv.mkDerivation rec {
+stage rec {
name = "gridss-assemble";
- buildInputs = [ jre bwa ];
+ buildInputs = with pkgs; [ jre bwa ];
buildCommand = ''
TMPDIR=$(pwd)
ln -s ${ref} ref.fa