aboutsummaryrefslogtreecommitdiff
path: root/tools/kallisto-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/kallisto-index.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/kallisto-index.nix')
-rw-r--r--tools/kallisto-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/kallisto-index.nix b/tools/kallisto-index.nix
index 33dfb80..3b92d38 100644
--- a/tools/kallisto-index.nix
+++ b/tools/kallisto-index.nix
@@ -1,11 +1,10 @@
{bionix
-, nixpkgs
, kmerSize ? 31
, unique ? false}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (kmerSize > 1);
@@ -13,9 +12,9 @@ input:
assert (matchFiletype input { fa = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "kallisto-index";
- buildInputs = [ kallisto ];
+ buildInputs = with pkgs; [ kallisto ];
buildCommand = ''
kallisto index -k ${toString kmerSize} ${optionalString unique "--make-unique"} -i $out ${input}
'';