aboutsummaryrefslogtreecommitdiff
path: root/tools/kallisto-quant.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/kallisto-quant.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/kallisto-quant.nix')
-rw-r--r--tools/kallisto-quant.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/tools/kallisto-quant.nix b/tools/kallisto-quant.nix
index 3efeaaa..b7481d8 100644
--- a/tools/kallisto-quant.nix
+++ b/tools/kallisto-quant.nix
@@ -1,5 +1,5 @@
-{bionix
-, indexFlags ? {}
+{ bionix
+, indexFlags ? { }
, bias ? false
, bootstrapSamples ? 0
, seed ? 42
@@ -10,7 +10,8 @@
, rfStranded ? false
, fragmentLength ? null
, fragmentSD ? null
-, ref}:
+, ref
+}:
with bionix;
with lib;
@@ -21,7 +22,7 @@ inputs:
let
inherit (bionix.types) matchFiletype';
- isFastQ = matchFiletype' "kallisto-quant" {fq = _: true; gz = isFastQ; };
+ isFastQ = matchFiletype' "kallisto-quant" { fq = _: true; gz = isFastQ; };
empty = ./kallisto-quant-empty.h5;
@@ -45,7 +46,7 @@ let
in
-assert (all (x: isFastQ (x.filetype)) inputs);
+assert (all (x: isFastQ x.filetype) inputs);
stage {
name = "kallisto-quant";