aboutsummaryrefslogtreecommitdiff
path: root/tools/manta-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/manta-call.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/manta-call.nix')
-rw-r--r--tools/manta-call.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/manta-call.nix b/tools/manta-call.nix
index 099d5e6..21cbeba 100644
--- a/tools/manta-call.nix
+++ b/tools/manta-call.nix
@@ -1,6 +1,6 @@
-{ bionix, indexAttrs ? {}, faidxAttrs ? {}, flags ? "" }:
+{ bionix, indexAttrs ? { }, faidxAttrs ? { }, flags ? "" }:
-{ normals ? [], tumour ? null }:
+{ normals ? [ ], tumour ? null }:
with bionix;
with lib;
@@ -8,7 +8,7 @@ with types;
let
getref = matchFiletype "manta-call" { bam = x: x.ref; };
- refs = map getref normals ++ optionals (tumour != null) [(getref tumour)];
+ refs = map getref normals ++ optionals (tumour != null) [ (getref tumour) ];
ref = head refs;
renameAndIndex = f: stage {