aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-plot.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/mosdepth-plot.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/mosdepth-plot.nix')
-rw-r--r--tools/mosdepth-plot.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/mosdepth-plot.nix b/tools/mosdepth-plot.nix
index f15e099..0fdfc67 100644
--- a/tools/mosdepth-plot.nix
+++ b/tools/mosdepth-plot.nix
@@ -1,17 +1,16 @@
{ bionix
-, nixpkgs
, flags ? null
}:
-with nixpkgs;
+with bionix;
with lib;
{ inputs
, names ? []}:
-stdenv.mkDerivation {
+stage {
name = "mosdepth-depth";
- buildInputs = [ python ];
+ buildInputs = with pkgs; [ python ];
buildCommand = ''
python ${mosdepth.src}/scripts/plot-dist.py ${concatMapStringsSep " " (i: "${i}/out.mosdepth.global.dist.txt") inputs}
${concatStringsSep "\n" (zipListsWith (i: n: "substituteInPlace dist.html --replace ${i}/out ${n}") inputs names)}