aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-plot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mosdepth-plot.nix')
-rw-r--r--tools/mosdepth-plot.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/mosdepth-plot.nix b/tools/mosdepth-plot.nix
index f15e099..0fdfc67 100644
--- a/tools/mosdepth-plot.nix
+++ b/tools/mosdepth-plot.nix
@@ -1,17 +1,16 @@
{ bionix
-, nixpkgs
, flags ? null
}:
-with nixpkgs;
+with bionix;
with lib;
{ inputs
, names ? []}:
-stdenv.mkDerivation {
+stage {
name = "mosdepth-depth";
- buildInputs = [ python ];
+ buildInputs = with pkgs; [ python ];
buildCommand = ''
python ${mosdepth.src}/scripts/plot-dist.py ${concatMapStringsSep " " (i: "${i}/out.mosdepth.global.dist.txt") inputs}
${concatStringsSep "\n" (zipListsWith (i: n: "substituteInPlace dist.html --replace ${i}/out ${n}") inputs names)}