aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
committerJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
commitc7756678c8a543f216654d518eeee3c4bd6a4b8f (patch)
tree098183330e8d7f5505570e7769a985eef83ecc51 /tools/mosdepth.nix
parentcac21d3ab1fd96724b568f675794c83273a27aee (diff)
add inline documentation
Diffstat (limited to 'tools/mosdepth.nix')
-rw-r--r--tools/mosdepth.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/mosdepth.nix b/tools/mosdepth.nix
index a5083a7..cbebdfb 100644
--- a/tools/mosdepth.nix
+++ b/tools/mosdepth.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Compute coverage of a reference given an alignemnt
+ Type: { ... } -> bam -> mosdepth
+ */
depth = callBionixE ./mosdepth-depth.nix;
+
+ /* Plot sample coverages. Names are optional.
+ Type: { ... } -> { inputs :: [mosdepth], names :: [string] } -> html
+ */
plot = callBionixE ./mosdepth-plot.nix;
}