aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mosdepth.nix')
-rw-r--r--tools/mosdepth.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/mosdepth.nix b/tools/mosdepth.nix
index a5083a7..cbebdfb 100644
--- a/tools/mosdepth.nix
+++ b/tools/mosdepth.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Compute coverage of a reference given an alignemnt
+ Type: { ... } -> bam -> mosdepth
+ */
depth = callBionixE ./mosdepth-depth.nix;
+
+ /* Plot sample coverages. Names are optional.
+ Type: { ... } -> { inputs :: [mosdepth], names :: [string] } -> html
+ */
plot = callBionixE ./mosdepth-plot.nix;
}