aboutsummaryrefslogtreecommitdiff
path: root/tools/mutect-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/mutect-call.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/mutect-call.nix')
-rw-r--r--tools/mutect-call.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/tools/mutect-call.nix b/tools/mutect-call.nix
index e98ba4b..52c1e1d 100644
--- a/tools/mutect-call.nix
+++ b/tools/mutect-call.nix
@@ -1,21 +1,22 @@
-{bionix
+{ bionix
, cosmic
-, dbsnp}:
+, dbsnp
+}:
with bionix;
with lib;
let
inherit (types) matchFiletype;
- getVCFref = matchFiletype "mutect-call" {vcf = {ref}: ref;};
- getBAMref = matchFiletype "mutect-call" {bam = {ref, ...}: ref;};
+ getVCFref = matchFiletype "mutect-call" { vcf = { ref }: ref; };
+ getBAMref = matchFiletype "mutect-call" { bam = { ref, ... }: ref; };
refs = map getVCFref [ cosmic dbsnp ];
ref = head refs;
in
assert (length (unique refs) == 1);
-{normal, tumour}:
+{ normal, tumour }:
assert (ref == getBAMref normal && ref == getBAMref tumour);