aboutsummaryrefslogtreecommitdiff
path: root/tools/mutect-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mutect-call.nix')
-rw-r--r--tools/mutect-call.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/tools/mutect-call.nix b/tools/mutect-call.nix
index e98ba4b..52c1e1d 100644
--- a/tools/mutect-call.nix
+++ b/tools/mutect-call.nix
@@ -1,21 +1,22 @@
-{bionix
+{ bionix
, cosmic
-, dbsnp}:
+, dbsnp
+}:
with bionix;
with lib;
let
inherit (types) matchFiletype;
- getVCFref = matchFiletype "mutect-call" {vcf = {ref}: ref;};
- getBAMref = matchFiletype "mutect-call" {bam = {ref, ...}: ref;};
+ getVCFref = matchFiletype "mutect-call" { vcf = { ref }: ref; };
+ getBAMref = matchFiletype "mutect-call" { bam = { ref, ... }: ref; };
refs = map getVCFref [ cosmic dbsnp ];
ref = head refs;
in
assert (length (unique refs) == 1);
-{normal, tumour}:
+{ normal, tumour }:
assert (ref == getBAMref normal && ref == getBAMref tumour);