aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/octopus-call.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/octopus-call.nix')
-rw-r--r--tools/octopus-call.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/octopus-call.nix b/tools/octopus-call.nix
index 80092e0..81619b6 100644
--- a/tools/octopus-call.nix
+++ b/tools/octopus-call.nix
@@ -18,7 +18,7 @@ with types;
inputs:
let
- getref = f: matchFiletype "octopus-call" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; } f;
+ getref = matchFiletype "octopus-call" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
@@ -63,6 +63,6 @@ stage {
${optionalString (targets != null) (handleTarget targets)} \
${flags}
'';
- passthru.filetype = filetype.vcf { ref = ref; };
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}