aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/octopus-call.nix')
-rw-r--r--tools/octopus-call.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/octopus-call.nix b/tools/octopus-call.nix
index 80092e0..81619b6 100644
--- a/tools/octopus-call.nix
+++ b/tools/octopus-call.nix
@@ -18,7 +18,7 @@ with types;
inputs:
let
- getref = f: matchFiletype "octopus-call" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; } f;
+ getref = matchFiletype "octopus-call" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
@@ -63,6 +63,6 @@ stage {
${optionalString (targets != null) (handleTarget targets)} \
${flags}
'';
- passthru.filetype = filetype.vcf { ref = ref; };
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}