aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-callSomatic.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/octopus-callSomatic.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/octopus-callSomatic.nix')
-rw-r--r--tools/octopus-callSomatic.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/octopus-callSomatic.nix b/tools/octopus-callSomatic.nix
index 401eeb8..df41550 100644
--- a/tools/octopus-callSomatic.nix
+++ b/tools/octopus-callSomatic.nix
@@ -31,7 +31,7 @@ let
'';
inputs = [ normal ] ++ tumours;
- getref = f: matchFiletype "octopus-callSomatic" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; } f;
+ getref = matchFiletype "octopus-callSomatic" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
@@ -77,6 +77,6 @@ stage {
-N $normal \
${flags}
'';
- passthru.filetype = filetype.vcf { ref = ref; };
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}