aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-callSomatic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/octopus-callSomatic.nix')
-rw-r--r--tools/octopus-callSomatic.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/octopus-callSomatic.nix b/tools/octopus-callSomatic.nix
index 401eeb8..df41550 100644
--- a/tools/octopus-callSomatic.nix
+++ b/tools/octopus-callSomatic.nix
@@ -31,7 +31,7 @@ let
'';
inputs = [ normal ] ++ tumours;
- getref = f: matchFiletype "octopus-callSomatic" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; } f;
+ getref = matchFiletype "octopus-callSomatic" { bam = { ref, ... }: ref; cram = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
@@ -77,6 +77,6 @@ stage {
-N $normal \
${flags}
'';
- passthru.filetype = filetype.vcf { ref = ref; };
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}