aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus-callSomatic.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-02-28 20:53:00 +1100
committerJustin Bedo <cu@cua0.org>2022-03-09 13:57:07 +1100
commitc4255587d157100db3bc05fa1feba4f16ffe140c (patch)
treea65f0f07163716a20413fb6dbf6ab3788c979d36 /tools/octopus-callSomatic.nix
parente67120ee854880c6c47628baddb6218adfeec81c (diff)
octopus: strip ARGV line to prevent huge closures
Diffstat (limited to 'tools/octopus-callSomatic.nix')
-rw-r--r--tools/octopus-callSomatic.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/octopus-callSomatic.nix b/tools/octopus-callSomatic.nix
index f2e264c..b6106a7 100644
--- a/tools/octopus-callSomatic.nix
+++ b/tools/octopus-callSomatic.nix
@@ -77,7 +77,11 @@ stage {
${optionalString (targets != null) (handleTarget targets)} \
-N $normal \
${flags}
+
+ # Strip out octopus ARGV
+ sed -i '/^##octopus=/d' $out
'';
passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
+ stripStorePaths = false;
}