aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
committerJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
commitc7756678c8a543f216654d518eeee3c4bd6a4b8f (patch)
tree098183330e8d7f5505570e7769a985eef83ecc51 /tools/octopus.nix
parentcac21d3ab1fd96724b568f675794c83273a27aee (diff)
add inline documentation
Diffstat (limited to 'tools/octopus.nix')
-rw-r--r--tools/octopus.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/octopus.nix b/tools/octopus.nix
index 4d0c7f6..858d133 100644
--- a/tools/octopus.nix
+++ b/tools/octopus.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Call variants for a population
+ Type: { fast :: bool, very-fast :: bool, max-genotypes :: int, targets :: FilePath + [string], ... } -> [bam] -> vcf
+ */
call = callBionixE ./octopus-call.nix;
+
+ /* Call somatic variants
+ Type: { fast :: bool, very-fast :: bool, max-genotypes :: int, targets :: FilePath + [string], ... } -> { normal :: bam, tumours :: [bam] } -> vcf
+ */
callSomatic = callBionixE ./octopus-callSomatic.nix;
}