aboutsummaryrefslogtreecommitdiff
path: root/tools/octopus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/octopus.nix')
-rw-r--r--tools/octopus.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/octopus.nix b/tools/octopus.nix
index 4d0c7f6..858d133 100644
--- a/tools/octopus.nix
+++ b/tools/octopus.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Call variants for a population
+ Type: { fast :: bool, very-fast :: bool, max-genotypes :: int, targets :: FilePath + [string], ... } -> [bam] -> vcf
+ */
call = callBionixE ./octopus-call.nix;
+
+ /* Call somatic variants
+ Type: { fast :: bool, very-fast :: bool, max-genotypes :: int, targets :: FilePath + [string], ... } -> { normal :: bam, tumours :: [bam] } -> vcf
+ */
callSomatic = callBionixE ./octopus-callSomatic.nix;
}