aboutsummaryrefslogtreecommitdiff
path: root/tools/pizzly-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-02-07 14:37:43 +1100
committerJustin Bedo <cu@cua0.org>2022-02-07 14:38:44 +1100
commit20050d08b1d6b18f437d7ac44a4720f2c24d7f53 (patch)
treec62e9b25190fa60bbcbfca285a4a4bbbb3c260d5 /tools/pizzly-call.nix
parent55fa3d7ffc3d3793219afb7d92b7ac2de9d6ce55 (diff)
pizzly: init
Diffstat (limited to 'tools/pizzly-call.nix')
-rw-r--r--tools/pizzly-call.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/pizzly-call.nix b/tools/pizzly-call.nix
new file mode 100644
index 0000000..72e23bf
--- /dev/null
+++ b/tools/pizzly-call.nix
@@ -0,0 +1,24 @@
+{ bionix, kmerSize ? 31, gtf, cdna, alignScore ? 2, maxInsertSize ? 400 }:
+
+with bionix;
+with pkgs;
+
+input:
+stage {
+ name = "pizzly";
+ buildInputs = [ bionix.pizzly.app ];
+ buildCommand = ''
+ ln -s ${gtf} ref.gtf
+ ln -s ${cdna} ref.fa
+ mkdir $out
+ pizzly \
+ -G ref.gtf \
+ -C cache \
+ -F ref.fa \
+ -k ${toString kmerSize} \
+ -o $out/output \
+ -a ${toString alignScore} \
+ -i ${toString maxInsertSize} \
+ ${input}/fusion.txt
+ '';
+}