aboutsummaryrefslogtreecommitdiff
path: root/tools/pizzly-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/pizzly-call.nix')
-rw-r--r--tools/pizzly-call.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/pizzly-call.nix b/tools/pizzly-call.nix
new file mode 100644
index 0000000..72e23bf
--- /dev/null
+++ b/tools/pizzly-call.nix
@@ -0,0 +1,24 @@
+{ bionix, kmerSize ? 31, gtf, cdna, alignScore ? 2, maxInsertSize ? 400 }:
+
+with bionix;
+with pkgs;
+
+input:
+stage {
+ name = "pizzly";
+ buildInputs = [ bionix.pizzly.app ];
+ buildCommand = ''
+ ln -s ${gtf} ref.gtf
+ ln -s ${cdna} ref.fa
+ mkdir $out
+ pizzly \
+ -G ref.gtf \
+ -C cache \
+ -F ref.fa \
+ -k ${toString kmerSize} \
+ -o $out/output \
+ -a ${toString alignScore} \
+ -i ${toString maxInsertSize} \
+ ${input}/fusion.txt
+ '';
+}