aboutsummaryrefslogtreecommitdiff
path: root/tools/platypus-callVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/platypus-callVariants.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/platypus-callVariants.nix')
-rw-r--r--tools/platypus-callVariants.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/platypus-callVariants.nix b/tools/platypus-callVariants.nix
index bb0faf1..59a224b 100644
--- a/tools/platypus-callVariants.nix
+++ b/tools/platypus-callVariants.nix
@@ -1,6 +1,6 @@
{ bionix
-, indexAttrs ? {}
-, bamIndexAttrs ? {}
+, indexAttrs ? { }
+, bamIndexAttrs ? { }
, flags ? null
}:
@@ -13,7 +13,7 @@ with types;
let
filename = path: last (splitString "/" path);
- getref = f: matchFiletype "platypus-callVariants" { bam = {ref, ...}: ref; } f;
+ getref = matchFiletype "platypus-callVariants" { bam = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
in
@@ -38,6 +38,6 @@ stage {
# Remove timestamps from output
sed -i '/^##fileDate/d' $out
'';
- passthru.filetype = filetype.vcf {ref = ref;};
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}