aboutsummaryrefslogtreecommitdiff
path: root/tools/platypus-callVariants.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/platypus-callVariants.nix')
-rw-r--r--tools/platypus-callVariants.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/platypus-callVariants.nix b/tools/platypus-callVariants.nix
index bb0faf1..59a224b 100644
--- a/tools/platypus-callVariants.nix
+++ b/tools/platypus-callVariants.nix
@@ -1,6 +1,6 @@
{ bionix
-, indexAttrs ? {}
-, bamIndexAttrs ? {}
+, indexAttrs ? { }
+, bamIndexAttrs ? { }
, flags ? null
}:
@@ -13,7 +13,7 @@ with types;
let
filename = path: last (splitString "/" path);
- getref = f: matchFiletype "platypus-callVariants" { bam = {ref, ...}: ref; } f;
+ getref = matchFiletype "platypus-callVariants" { bam = { ref, ... }: ref; };
refs = map getref inputs;
ref = head refs;
in
@@ -38,6 +38,6 @@ stage {
# Remove timestamps from output
sed -i '/^##fileDate/d' $out
'';
- passthru.filetype = filetype.vcf {ref = ref;};
+ passthru.filetype = filetype.vcf { inherit ref; };
passthru.multicore = true;
}