aboutsummaryrefslogtreecommitdiff
path: root/tools/quip-quip.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-05-16 12:46:12 +1000
committerJustin Bedo <cu@cua0.org>2022-05-16 13:07:24 +1000
commit2bd2c3958ed91ef3bbea2fc3e077a8c03a648a1b (patch)
tree8d12d5f861a0ef6194fdd055586527ab998b151e /tools/quip-quip.nix
parent61a05c73159f4578322ba9a59ab8ee7a5f1fb1b4 (diff)
quip: init
Diffstat (limited to 'tools/quip-quip.nix')
-rw-r--r--tools/quip-quip.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/quip-quip.nix b/tools/quip-quip.nix
new file mode 100644
index 0000000..77cf557
--- /dev/null
+++ b/tools/quip-quip.nix
@@ -0,0 +1,17 @@
+{bionix}:
+with bionix;
+with lib.types;
+ input: let
+ ref = matchFiletype "quip" {bam = f: f.ref;} input;
+ in
+ stage {
+ name = "quip";
+ buildInputs = [quip.app];
+ buildCommand = ''
+ ln -s ${input} input.bam
+ quip -r ${ref} input.bam
+ cp input.bam.qp $out
+ '';
+ stripStorePaths = false;
+ passthru.filetype = filetype.qp input.filetype;
+ }