aboutsummaryrefslogtreecommitdiff
path: root/tools/quip-unquip.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-05-16 12:46:12 +1000
committerJustin Bedo <cu@cua0.org>2022-05-16 13:07:24 +1000
commit2bd2c3958ed91ef3bbea2fc3e077a8c03a648a1b (patch)
tree8d12d5f861a0ef6194fdd055586527ab998b151e /tools/quip-unquip.nix
parent61a05c73159f4578322ba9a59ab8ee7a5f1fb1b4 (diff)
quip: init
Diffstat (limited to 'tools/quip-unquip.nix')
-rw-r--r--tools/quip-unquip.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/quip-unquip.nix b/tools/quip-unquip.nix
new file mode 100644
index 0000000..8c9cc01
--- /dev/null
+++ b/tools/quip-unquip.nix
@@ -0,0 +1,18 @@
+{bionix}:
+with bionix;
+with lib.types;
+ input: let
+ bamft = matchFiletype "unquip" {qp = x: x;} input;
+ ref = matchFiletype' "unquip-sub" {bam = f: f.ref;} bamft;
+ in
+ stage {
+ name = "unquip";
+ buildInputs = [quip.app];
+ buildCommand = ''
+ ln -s ${input} input.bam.qp
+ unquip -r ${ref} input.bam.qp
+ cp input.bam $out
+ '';
+ stripStorePaths = false;
+ passthru.filetype = bamft;
+ }