aboutsummaryrefslogtreecommitdiff
path: root/tools/quip-unquip.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/quip-unquip.nix')
-rw-r--r--tools/quip-unquip.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/quip-unquip.nix b/tools/quip-unquip.nix
new file mode 100644
index 0000000..8c9cc01
--- /dev/null
+++ b/tools/quip-unquip.nix
@@ -0,0 +1,18 @@
+{bionix}:
+with bionix;
+with lib.types;
+ input: let
+ bamft = matchFiletype "unquip" {qp = x: x;} input;
+ ref = matchFiletype' "unquip-sub" {bam = f: f.ref;} bamft;
+ in
+ stage {
+ name = "unquip";
+ buildInputs = [quip.app];
+ buildCommand = ''
+ ln -s ${input} input.bam.qp
+ unquip -r ${ref} input.bam.qp
+ cp input.bam $out
+ '';
+ stripStorePaths = false;
+ passthru.filetype = bamft;
+ }