aboutsummaryrefslogtreecommitdiff
path: root/tools/sambamba.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-11-16 11:59:41 +1100
committerJustin Bedo <cu@cua0.org>2020-11-16 11:59:41 +1100
commit05da61d166d7d4702001510a5eaa1935102d24f0 (patch)
treec75febaeeaaa79e1bd109ec28d717d13a5b43dd5 /tools/sambamba.nix
parenta50933a96096d53c341b30d487362d0913977574 (diff)
sambamba: init
Diffstat (limited to 'tools/sambamba.nix')
-rw-r--r--tools/sambamba.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/sambamba.nix b/tools/sambamba.nix
new file mode 100644
index 0000000..552e6e3
--- /dev/null
+++ b/tools/sambamba.nix
@@ -0,0 +1,15 @@
+{ bionix }:
+
+with bionix;
+
+let
+ gen = callBionixE ./sambamba-generic.nix;
+
+in {
+ sort = callBionixE ./sambamba-sort.nix;
+ index = def gen {tool = "index"; };
+ merge = def gen {tool = "merge"; };
+ slice = def gen {tool = "slice"; };
+ flagstat = def gen {tool = "flagstat"; };
+ markdup = def gen {tool = "markdup"; };
+}