aboutsummaryrefslogtreecommitdiff
path: root/tools/sambamba.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/sambamba.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/sambamba.nix')
-rw-r--r--tools/sambamba.nix25
1 files changed, 13 insertions, 12 deletions
diff --git a/tools/sambamba.nix b/tools/sambamba.nix
index 3c1d1fd..77289fe 100644
--- a/tools/sambamba.nix
+++ b/tools/sambamba.nix
@@ -5,34 +5,35 @@ with bionix;
let
gen = callBionixE ./sambamba-generic.nix;
-in {
+in
+{
/* Sort aligned reads
- Type: { nameSort :: bool, ... } -> bam -> bam
+ Type: { nameSort :: bool, ... } -> bam -> bam
*/
sort = callBionixE ./sambamba-sort.nix;
/* Build an index
- Type: { ... } -> bam -> index
+ Type: { ... } -> bam -> index
*/
- index = def gen {tool = "index"; };
+ index = def gen { tool = "index"; };
/* Merge bam files
- Type: { ... } -> [bam] -> bam
+ Type: { ... } -> [bam] -> bam
*/
- merge = def gen {tool = "merge"; };
+ merge = def gen { tool = "merge"; };
/* Slice a region out of a bam file
- Type: { region, ... } -> bam -> bam
+ Type: { region, ... } -> bam -> bam
*/
- slice = def gen {tool = "slice"; };
+ slice = def gen { tool = "slice"; };
/* Compute flag statistics
- Type: { ... } -> bam -> flagstat
+ Type: { ... } -> bam -> flagstat
*/
- flagstat = def gen {tool = "flagstat"; };
+ flagstat = def gen { tool = "flagstat"; };
/* Mark duplicates
- Type: { ... } -> bam -> bam
+ Type: { ... } -> bam -> bam
*/
- markdup = def gen {tool = "markdup"; };
+ markdup = def gen { tool = "markdup"; };
}