aboutsummaryrefslogtreecommitdiff
path: root/tools/sambamba.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
committerJustin Bedo <cu@cua0.org>2021-02-03 11:49:23 +1100
commitc7756678c8a543f216654d518eeee3c4bd6a4b8f (patch)
tree098183330e8d7f5505570e7769a985eef83ecc51 /tools/sambamba.nix
parentcac21d3ab1fd96724b568f675794c83273a27aee (diff)
add inline documentation
Diffstat (limited to 'tools/sambamba.nix')
-rw-r--r--tools/sambamba.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/sambamba.nix b/tools/sambamba.nix
index 552e6e3..3c1d1fd 100644
--- a/tools/sambamba.nix
+++ b/tools/sambamba.nix
@@ -6,10 +6,33 @@ let
gen = callBionixE ./sambamba-generic.nix;
in {
+ /* Sort aligned reads
+ Type: { nameSort :: bool, ... } -> bam -> bam
+ */
sort = callBionixE ./sambamba-sort.nix;
+
+ /* Build an index
+ Type: { ... } -> bam -> index
+ */
index = def gen {tool = "index"; };
+
+ /* Merge bam files
+ Type: { ... } -> [bam] -> bam
+ */
merge = def gen {tool = "merge"; };
+
+ /* Slice a region out of a bam file
+ Type: { region, ... } -> bam -> bam
+ */
slice = def gen {tool = "slice"; };
+
+ /* Compute flag statistics
+ Type: { ... } -> bam -> flagstat
+ */
flagstat = def gen {tool = "flagstat"; };
+
+ /* Mark duplicates
+ Type: { ... } -> bam -> bam
+ */
markdup = def gen {tool = "markdup"; };
}