aboutsummaryrefslogtreecommitdiff
path: root/tools/sambamba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/sambamba.nix')
-rw-r--r--tools/sambamba.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/sambamba.nix b/tools/sambamba.nix
index 552e6e3..3c1d1fd 100644
--- a/tools/sambamba.nix
+++ b/tools/sambamba.nix
@@ -6,10 +6,33 @@ let
gen = callBionixE ./sambamba-generic.nix;
in {
+ /* Sort aligned reads
+ Type: { nameSort :: bool, ... } -> bam -> bam
+ */
sort = callBionixE ./sambamba-sort.nix;
+
+ /* Build an index
+ Type: { ... } -> bam -> index
+ */
index = def gen {tool = "index"; };
+
+ /* Merge bam files
+ Type: { ... } -> [bam] -> bam
+ */
merge = def gen {tool = "merge"; };
+
+ /* Slice a region out of a bam file
+ Type: { region, ... } -> bam -> bam
+ */
slice = def gen {tool = "slice"; };
+
+ /* Compute flag statistics
+ Type: { ... } -> bam -> flagstat
+ */
flagstat = def gen {tool = "flagstat"; };
+
+ /* Mark duplicates
+ Type: { ... } -> bam -> bam
+ */
markdup = def gen {tool = "markdup"; };
}