aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-sort.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-10 07:43:04 +1100
committerJustin Bedo <cu@cua0.org>2019-01-10 07:43:04 +1100
commitc6ea8db2830f99195cc74bc3e59992324a8c0480 (patch)
treee0af4efeaebdf45affdcdae3ef524c29b3911def /tools/samtools-sort.nix
parentc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (diff)
refactor missed stages
Diffstat (limited to 'tools/samtools-sort.nix')
-rw-r--r--tools/samtools-sort.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/samtools-sort.nix b/tools/samtools-sort.nix
index 6f9eb33..d01c83f 100644
--- a/tools/samtools-sort.nix
+++ b/tools/samtools-sort.nix
@@ -19,7 +19,7 @@ let
outfmtR = if outfmt != null then outfmt input else input.filetype;
outFmtFlags = matchFiletype "samtools-sort-outfmt" { bam = _: "-O BAM"; sam = _: "-O SAM"; cram = ref: "-O CRAM -T ${ref}"; } {filetype = outfmtR;};
alreadySorted = matchFileSorting "samtools-sort" { name = _: nameSort; coord = _: !nameSort; none = _: false;} input;
-in pkgs.stdenv.mkDerivation {
+in stage {
name = "samtools-sort";
buildInputs = with pkgs; [ samtools ];
buildCommand =