aboutsummaryrefslogtreecommitdiff
path: root/tools/star-align.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-07-28 08:07:32 +1000
committerJustin Bedo <cu@cua0.org>2021-07-28 09:17:56 +1000
commited98174bbefc85f9895c870fdb7518e2a534a150 (patch)
tree913c1eb5cb384213d22af6cf4f4e2b8fd2a51276 /tools/star-align.nix
parent134f5e0bfcd5f22e3adee4b707e10693cf71e635 (diff)
bugfix: use unsorted type for alignment output
Most aligners are only pseudo-name sorted (i.e., pairs adjacant).
Diffstat (limited to 'tools/star-align.nix')
-rw-r--r--tools/star-align.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/star-align.nix b/tools/star-align.nix
index 0cf9ab9..44dd7f2 100644
--- a/tools/star-align.nix
+++ b/tools/star-align.nix
@@ -33,6 +33,6 @@ in stage {
--readFilesIn ${fq input1} ${optionalString (input2 != null) (fq input2)}
${if bamOutput then "samtools view -b Aligned.out.sam > $out" else "cp Aligned.out.sam $out"}
'';
- passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.name {};} else filetype.sam {ref = ref; sorting = sort.name {};};
+ passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.none {};} else filetype.sam {ref = ref; sorting = sort.name {};};
passthru.multicore = true;
}