aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 14:20:31 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 14:20:31 +1000
commitb51c2989b0d354ab96077c6af559dc20c026d42f (patch)
tree90b67ba7164214a0c0a4fba40f55c9bc4182e7d8 /tools/strelka-call.nix
parent30d47b54b1e1ca63fb4a3bce26cc51a7b6017e23 (diff)
Refactor references
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index e7fbb58..ecdea84 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -19,8 +19,8 @@ in stdenv.mkDerivation {
name = "strelka";
buildInputs = [ strelka ];
buildCommand = ''
- ln -s ${ref} ref.fa
- ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai
+ ln -s ${ref.seq} ref.fa
+ ln -s ${bionix.samtools.faidx indexAttrs ref.seq} ref.fa.fai
${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}