aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
commitfe68926931b280aaf29808566b49b2e704e8556a (patch)
treedad0e9e11852e161c87ea6b7f4f6100a5180b9f2 /tools/strelka-call.nix
parent51f3817ecd2ad099b951d11e55eb3e2c516174d3 (diff)
Refactor to use bionix tree directly
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index ec7a764..e7fbb58 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -1,15 +1,14 @@
-{ stdenv
-, callPackage
-, lib
-, strelka
+{ bionix
+, nixpkgs
, ref
-, index ? callPackage ./samtools-faidx.nix {}
-, bamIndex ? callPackage ./samtools-index.nix {}
+, indexAttrs ? {}
+, bamIndexAttrs ? {}
, flags ? null
}:
{normal, tumour}:
+with nixpkgs;
with lib;
let
@@ -21,9 +20,9 @@ in stdenv.mkDerivation {
buildInputs = [ strelka ];
buildCommand = ''
ln -s ${ref} ref.fa
- ln -s ${index ref} ref.fa.fai
+ ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai
${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
- ${concatMapStringsSep "\n" (p: "ln -s ${bamIndex p} ${filename p}.bai") inputs}
+ ${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}
configureStrelkaSomaticWorkflow.py \
--normalBam ${filename normal}.bam \