aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index ec7a764..e7fbb58 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -1,15 +1,14 @@
-{ stdenv
-, callPackage
-, lib
-, strelka
+{ bionix
+, nixpkgs
, ref
-, index ? callPackage ./samtools-faidx.nix {}
-, bamIndex ? callPackage ./samtools-index.nix {}
+, indexAttrs ? {}
+, bamIndexAttrs ? {}
, flags ? null
}:
{normal, tumour}:
+with nixpkgs;
with lib;
let
@@ -21,9 +20,9 @@ in stdenv.mkDerivation {
buildInputs = [ strelka ];
buildCommand = ''
ln -s ${ref} ref.fa
- ln -s ${index ref} ref.fa.fai
+ ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai
${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
- ${concatMapStringsSep "\n" (p: "ln -s ${bamIndex p} ${filename p}.bai") inputs}
+ ${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}
configureStrelkaSomaticWorkflow.py \
--normalBam ${filename normal}.bam \