aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-callSomatic.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-04-07 21:10:25 +1000
committerJustin Bedo <cu@cua0.org>2019-04-07 21:10:25 +1000
commite5a8870358713f4e44e135da913c50230d83d4f1 (patch)
tree9678b00f5b683f0d3df31c11ff2c96c0a597cb0f /tools/strelka-callSomatic.nix
parente97bc0b22b9f49d95d6b449b2b20e7222b42622d (diff)
modify outputs to ensure determinism
Diffstat (limited to 'tools/strelka-callSomatic.nix')
-rw-r--r--tools/strelka-callSomatic.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/strelka-callSomatic.nix b/tools/strelka-callSomatic.nix
index 256065b..cf4b414 100644
--- a/tools/strelka-callSomatic.nix
+++ b/tools/strelka-callSomatic.nix
@@ -40,7 +40,18 @@ stage {
-m local \
-j $NIX_BUILD_CORES
- cp -r results $out
+ # Strelka writes runtime stats and timestamps;
+ # both have to be stripped to provide determinism
+ cd results/variants
+ rm *.tbi
+ for f in *.vcf.gz; do
+ gunzip $f
+ g=$(basename $f .gz)
+ sed -i '/^##fileDate/d' $g
+ sed -i '/^##startTime/d' $g
+ done
+ mkdir $out
+ cp -r * $out
'';
passthru.multicore = true;
}